Browse Source

Requests should be a dev dependency

Getty Ritter 1 year ago
parent
commit
f013681080
2 changed files with 7 additions and 7 deletions
  1. 6 6
      poetry.lock
  2. 1 1
      pyproject.toml

+ 6 - 6
poetry.lock

@@ -50,7 +50,7 @@ typed-ast = ">=1.4.0"
 d = ["aiohttp (>=3.3.2)", "aiohttp-cors"]
 
 [[package]]
-category = "main"
+category = "dev"
 description = "Python package for providing Mozilla's CA Bundle."
 name = "certifi"
 optional = false
@@ -58,7 +58,7 @@ python-versions = "*"
 version = "2020.4.5.1"
 
 [[package]]
-category = "main"
+category = "dev"
 description = "Universal encoding detector for Python 2 and 3"
 name = "chardet"
 optional = false
@@ -119,7 +119,7 @@ docs = ["sphinx", "pallets-sphinx-themes", "sphinxcontrib-log-cabinet", "sphinx-
 dotenv = ["python-dotenv"]
 
 [[package]]
-category = "main"
+category = "dev"
 description = "Internationalized Domain Names in Applications (IDNA)"
 name = "idna"
 optional = false
@@ -299,7 +299,7 @@ python-versions = "*"
 version = "2020.4.4"
 
 [[package]]
-category = "main"
+category = "dev"
 description = "Python HTTP for Humans."
 name = "requests"
 optional = false
@@ -369,7 +369,7 @@ mypy-extensions = ">=0.3.0"
 typing-extensions = ">=3.7.4"
 
 [[package]]
-category = "main"
+category = "dev"
 description = "HTTP library with thread-safe connection pooling, file post, and more."
 name = "urllib3"
 optional = false
@@ -402,7 +402,7 @@ dev = ["pytest", "pytest-timeout", "coverage", "tox", "sphinx", "pallets-sphinx-
 watchdog = ["watchdog"]
 
 [metadata]
-content-hash = "fa1c292cf46b36b5154fa2dabccd2c9f059546de1af6570fa5b4ac42b08f65ee"
+content-hash = "b234a4bc338ab28baafcd0c86b36ed2c697809f494083455d2f88742ea51ac53"
 python-versions = "^3.8"
 
 [metadata.files]

+ 1 - 1
pyproject.toml

@@ -9,13 +9,13 @@ python = "^3.8"
 flask = "^1.1.2"
 peewee = "^3.13.2"
 pystache = "^0.5.4"
-requests = "^2.23.0"
 dataclasses-json = "^0.4.2"
 
 [tool.poetry.dev-dependencies]
 pytest = "^5.4.1"
 invoke = "^1.4.1"
 black = "^19.10b0"
+requests = "^2.23.0"
 
 [build-system]
 requires = ["poetry>=0.12"]